D-Bus Support Is Here

The latest Rhythmbox Applet code in the Arch repository now has D-Bus support. More to the point, Rhythmbox Applet now works with Rhythmbox CVS!

For D-Bus support to work, you’ll need:

  • A recent copy of Rhythmbox from CVS.
  • The latest Rhythmbox Applet code from Arch.
  • D-Bus 0.35 or later.

If you still use Rhythmbox 0.8.8 or earlier, you can still use Rhythmbox Applet without any difficulties. The applet looks for both D-Bus and Bonobo and uses whichever one is available automatically. That means you can switch between Rhythmbox 0.8.8 and Rhythmbox CVS all you want without needing to do anything to the applet!

However, Rhythmbox Applet will not support Rhythmbox 0.9.0 or 0.9.1, and probably never will. Although those versions of Rhythmbox do have a D-Bus interface, they don’t provide the functionality that the applet needs. The necessary enhancements were added to CVS shortly after 0.9.1 was released, so until 0.9.2 comes out, you’ll need to either stick with 0.8.8 or grab what’s in CVS.

If you have any problems with the latest Rhythmbox Applet code, please let me know.

Comments are closed.